Author Topic: Forum bugs  (Read 614 times)

0 Members and 1 Guest are viewing this topic.

Offline michih

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1005
  • Gender: Male
  • Last Login:Today at 01:04:26 pm
Forum bugs
« on: March 23, 2016, 03:35:02 pm »
Where should forum bugs be submitted? I think the source code is not hosted on github (or I couldn't find it). Should it be reported in this board or in the 'Web Design Discussion' board?

I've detected two bugs:
1. Time conversion seems to be wrong. The time is currently one hour ahead for CET. I guess it's because US already has DST but Europe will change next weekend.
2. The "new" notification (grey icon) disappears on the main page ("Home") if one opens a board and directly returns to "Home" without opening the thread with the "new" notification.

Offline si404

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 679
  • Last Login:Today at 01:09:33 pm
Re: Forum bugs
« Reply #1 on: March 23, 2016, 03:40:25 pm »
1. Time conversion seems to be wrong. The time is currently one hour ahead for CET. I guess it's because US already has DST but Europe will change next weekend.
Indeed it is. I'm not sure I've been on a forum that pulls this off correctly and one group of people always end up having wrong time stamps due to different dates when clocks change.

Offline rickmastfan67

  • TM Collaborator (A)
  • Sr. Member
  • *****
  • Posts: 478
  • Gender: Male
  • Last Login:July 13, 2018, 08:16:03 am
Re: Forum bugs
« Reply #2 on: March 24, 2016, 07:47:29 am »
I've detected two bugs:
1. Time conversion seems to be wrong. The time is currently one hour ahead for CET. I guess it's because US already has DST but Europe will change next weekend.

Pretty sure this is based off the 'server' time (where the site is hosted).  No control over that one.  Just have to live with it by manually updating your offset in your profile, or just wait till it's back in sync.

2. The "new" notification (grey icon) disappears on the main page ("Home") if one opens a board and directly returns to "Home" without opening the thread with the "new" notification.

Not a bug, as it's intentionally done that way.  That icon only shows up when something new has been posted since you've last visit in that section.  Doesn't matter if there is an older 'NEW' post there.

Offline michih

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1005
  • Gender: Male
  • Last Login:Today at 01:04:26 pm
Re: Forum bugs
« Reply #3 on: March 24, 2016, 11:13:48 am »
2. The "new" notification (grey icon) disappears on the main page ("Home") if one opens a board and directly returns to "Home" without opening the thread with the "new" notification.
Not a bug, as it's intentionally done that way.  That icon only shows up when something new has been posted since you've last visit in that section.  Doesn't matter if there is an older 'NEW' post there.

If I return to the board, the threads are still marked with "NEW" notification. I thought the icon on the main page should indicated that there are new posts within threads of the board. Maybe I misunderstood the icon...

Offline rickmastfan67

  • TM Collaborator (A)
  • Sr. Member
  • *****
  • Posts: 478
  • Gender: Male
  • Last Login:July 13, 2018, 08:16:03 am
Re: Forum bugs
« Reply #4 on: March 24, 2016, 07:10:18 pm »
2. The "new" notification (grey icon) disappears on the main page ("Home") if one opens a board and directly returns to "Home" without opening the thread with the "new" notification.
Not a bug, as it's intentionally done that way.  That icon only shows up when something new has been posted since you've last visit in that section.  Doesn't matter if there is an older 'NEW' post there.

If I return to the board, the threads are still marked with "NEW" notification. I thought the icon on the main page should indicated that there are new posts within threads of the board. Maybe I misunderstood the icon...

The 'NEW' icon on threads just notifies you that you haven't read some posts in that thread, and will stay that way till you read it, or mark all the threads in that section as 'read'.  This is just how the forum software works.