Author Topic: HEADS UP: TM and forum migration to new domain and server  (Read 3357 times)

0 Members and 1 Guest are viewing this topic.

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
HEADS UP: TM and forum migration to new domain and server
« on: June 02, 2018, 05:53:43 pm »
Much of this has been discussed in some other threads, some of which are in the part of the forum accessible only by site contributors.  So here's a quick update for everyone.

  • We are moving TM and this forum to a new physical server and new domain name, travelmapping.net.
  • In the process, the mapping engine is changing from Google Maps to Leaflet in response to Google's new terms of use that would expose our project to potential unexpected billing.
  • There should be no real downtime for the main site.  You can already access the new instance at travelmapping.net and you are encouraged to start using it now.  The old/existing tm.teresco.org URLs will be redirected there soon.
  • When this forum migrates over, there will be a few more steps and there will likely be some downtime.  I hope the old URLs will be able to remain functional, but that might not be possible.

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #1 on: June 04, 2018, 06:00:46 pm »
If all goes well, I'm going to try the migration tonight (Mon 6/4).  I think it should be mostly seamless but I expect some downtime for the forum while I put it into maintenance mode, take DB backup, move files over, restore the DB, and run one more script.  Hopefully the old URLs will all redirect but I don't promise it will all be perfect.

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #2 on: June 04, 2018, 09:54:16 pm »
If you are reading this, it means you have successfully connected to the new forum, and I successfully made my first post here.  There are bound to be problems.  Let me know if you see any.

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #3 on: June 04, 2018, 10:25:36 pm »
I think I've got everything updated and transferred, so new and old URLs will point at the new server (at least once DNS changes finish propagating).  Any tm.teresco.org URL should redirect to the corresponding travelmapping.net URL.  Forum URLs should redirect to forum.travelmapping.net .  I'm sure I've broken some things, so let me know when something looks broken.

If you really want to connect to the old server, you can at tmold.teresco.org for now.  I'll leave it for a few days anyway.

Offline froggie

  • TM Collaborator
  • Sr. Member
  • *****
  • Posts: 480
  • Last Login:Yesterday at 12:18:32 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #4 on: June 05, 2018, 04:56:54 pm »
Biggest problem I had was not remembering and subsequently resetting my forum password...

Offline Markkos1992

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 600
  • Last Login:Today at 05:27:28 am
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #5 on: June 05, 2018, 07:34:02 pm »
When I go to a state on the highway browser, the header above the routes is to the left of where it should be.  (using Chrome)

Offline oscar

  • TM Collaborator
  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 811
  • Last Login:Today at 03:35:38 am
    • Hot Springs and Highways pages
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #6 on: June 05, 2018, 08:15:39 pm »
When I go to a state on the highway browser, the header above the routes is to the left of where it should be.  (using Chrome)

Or other region: http://travelmapping.net/hb/?units=miles&u=oscar&rg=qc

Same issue in MS Edge, not just Chrome.

Offline rschen7754

  • Newbie
  • *
  • Posts: 41
  • Gender: Male
  • Last Login:September 12, 2019, 10:10:45 pm
    • Rschen7754
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #7 on: June 05, 2018, 08:41:18 pm »
I'm getting errors on clinched.php:


Warning: file_get_contents(/home/www/tm/shields/template_eure_wide.svg): failed to open stream: No such file or directory in /home/www/tm/shields/shieldgen.php on line 331

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #8 on: June 05, 2018, 10:20:21 pm »
When I go to a state on the highway browser, the header above the routes is to the left of where it should be.  (using Chrome)

That's weird.  Nothing obvious on a quick look at the code.

https://github.com/TravelMapping/Web/issues/270

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #9 on: June 05, 2018, 10:22:09 pm »
I'm getting errors on clinched.php:


Warning: file_get_contents(/home/www/tm/shields/template_eure_wide.svg): failed to open stream: No such file or directory in /home/www/tm/shields/shieldgen.php on line 331

This one's already a GitHub issue.

https://github.com/TravelMapping/Web/issues/261

Waiting for those who know the shield generator better than me to take a look.

Offline michih

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1749
  • Last Login:Today at 02:11:59 am
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #10 on: June 06, 2018, 03:29:56 am »
When I go to a state on the highway browser, the header above the routes is to the left of where it should be.  (using Chrome)

Same issue in MS Edge, not just Chrome.

It's a general issue, also with FF.

Offline vdeane

  • Full Member
  • ***
  • Posts: 127
  • Gender: Female
  • Last Login:Yesterday at 06:03:18 pm
    • New York State Roads
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #11 on: June 10, 2018, 12:40:48 am »
Was it intentional that the favicon wasn't transferred, or is that a bug?
Please note: All comments here represent my own personal opinion and do not reflect the official position of NYSDOT or its affiliates.

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #12 on: June 10, 2018, 08:15:05 am »
Was it intentional that the favicon wasn't transferred, or is that a bug?

Intentional.  That was copied over from CHM and I think we should have our own unique one.

Offline yakra

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 2129
  • Last Login:Today at 03:15:07 am
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #13 on: June 10, 2018, 12:52:13 pm »
I know It wasn't directly copied pixel-for-pixel; If I load up a page from tmold and a page from cmap side-by-side, the difference is easy to see.
The "motorway-check" was my idea originally, and I'm fine with TM using it as well.

Offline Jim

  • TM Collaborator
  • Hero Member
  • *****
  • Posts: 1532
  • Last Login:Yesterday at 10:11:34 pm
Re: HEADS UP: TM and forum migration to new domain and server
« Reply #14 on: June 10, 2018, 02:10:59 pm »
Good enough for me.  I put it up on the new server.